Development issue/problem:

I have an Android project that is fully developed in Android Studio (currently version 4.2, version 1.9-all). I want to add Google Play features.

The project cannot resolve GooglePlayServicesUtil, and when I enter the import manually (see below), I get the Cannot resolve common icon.

import com.google.android.gms.common.GooglePlayServicesUtil ;

Do you have any idea what you need to do to authorize GooglePlayServicesUtil?

In the Google Play services settings, it seems that I just need to add the com.google.android.gms:play-services:4.+ dependency to my build.gradle file (and resync the project files with gradle) to make the SDK available for my project. I get an inflated package in ProjectName/module/build/exploded bundles, but it doesn’t look like a gadget.

I have already installed Google Play services, Android support repository and Google repository from the SDK manager. I also uninstalled and reinstalled it several times.

Edit:

Can I manually add google_play_services as global project/library? I tried, but it didn’t work.

I try to check if I am developing according to the Platform API with Google services (if possible), but I’m not sure if this is the case. I can’t change anything.

The external libraries of my project are shown:

This is my ProjectName/module/build.gradle file:

build {repositories {mavenCentral()}dependencies {classpath ‘com.android.tools.build:gradle:0.7.+’}}dependencies {classpath ‘com.android.tools.build:gradle:0.7.+’}.

Application plug-in: android

Deposits {
mavenCentral()
}

android {
compileSdkVersion 19
buildToolsVersion ‘19.0.1’
defaultConfig {
minSdkVersion 17
targetSdkVersion 19
versionCode
versionName 1.0
} Compilation types
{ revision
{
runProguard true
proguardFiles getDefaultProguardFile(‘proguard-android.txt’), ‘proguard-rules.txt’
}
}
signature Correspondence {
} Product
Flavors {
}
}

Dependencies {
compiles ‘com.google.android.gms:play-services:4.+’
compiles ‘iodine-time:iodine-time : [protected via email]’
}

The version number com.google.android.gms.ru is perfectly solved in my manifesto. Here is my ProjectName/module/src/main/AndroidManifest.xml file:

Here is my MainActivity where I try to check if GooglePlayServices are available:

com.example.android package ;

import android.app.Activity ;
import android.os.bundle ;
import android.util.log ;

import com.google.android.gms.common.GooglePlayServicesUtil ;

the public MainActivity class expands the activity {
private static end string TAG = MainActivity ;

@Override
protected void onCreate(Bundle savedInstanceState) {
super.onCreate(savedInstanceState);
setContentView(R.layout.activity_main);
}

@Check public void
onResume() {
Log.i(TAG, onResume);
GooglePlayServicesUtil.isGooglePlayServicesAvailable(getApplicationContext());
}
}

How can I solve this problem?

Solution 1:

Try it once and make sure you don’t get an error in the project structure indicating that ComGoogleAndroidGmsPlay hasn’t been added.

Open the folder > Project structure and check below. If an error is displayed, click on the red light and click Add to Dependency.

Dependence on fuels and lubricants

This is a bug in Android Studio that will be fixed in the next version (0.4.3).

Solution 2:

I had a similar problem that I could not solve com.google.android.gms.common.

I followed the installation instructions on http://developer.android.com/google/play-services/setup.html and it works!

Synopsis:

  1. Install/update Google Play services and the Google Repository of the SDK Manager.
  2. Extra dependency to build the gradle: Compile com.google.android.gms:play-services:4.0.30.
  3. AndroidManifest.xml updated with

Solution 3:

I solved the problem by installing the Google Play Services package in the sdk manager.

Then create a new application and add the following to the build.gradle.

Compile com.google.android.gms:play-services:4.3.+.

Here’s how.

Dependencies {
compiles ‘com.android.support:appcompat-v7:+’
compiles ‘com.google.android.gms:play-services:4.3.+’
}.

Solution 4:

After hours of having the same problem, I realize that the problem occurs when the pot is in the libs folder, so I just comment on the dependencies in the file tree and keep the dependencies that are

Dependencies

//Compile the file tree (directory: ‘libs’, including: [‘*.jar’])

and the problem is solved.

Solution No 5:

I just tried your build.gradle and was able to import GMS, so that’s not the problem.

This is the case with Google Play (rev. 13) and Google Repository (rev. 4). Check if they are installed again

Solution No 6:

I have the same problem. I just tried to repair, clean and restart the device, but it didn’t help. So I’m just gonna

Compile com.google.android.gms:play-services:8.3.0.

from build.gradle and resync. Then I put it back together again and re-synchronized it. Then I clean up the project and the problem disappears !!!!.

I hope this will help anyone dealing with the same thing.

Solution No 7:

// degree. Characteristics.

systemProp.http.proxyHost=www.somehost.org

systemProp.http.proxyPort=8080

systemProp.http.proxyUser=userid

systemProp.http.proxyPassword=password

systemProp.http.nonProxyHosts=*.nonproxyrepos.com|localhost.

Good luck!

com googleandroid gms play-services,google play services api,google play services android,google play-services dependency,google play services modules,google play services version history,add google play services to android studio,google play services minimum android version,google play services apk,how to install google play services sdk in android studio,google play services download,google play services update download,google apis for android,failed to resolve com.google.android.gms play-services

You May Also Like

How to Auto-Delete Web Activity and Location History on Google

Related Tags:   automatically delete google search history,  google my activity,  google…

The Ten Best Assurance Wireless Upgrade Phone in 2021 [Reviews]

It’s 2021, and your wireless hotline needs an upgrade. If you are…

Solution: Malwarebytes runtime error – Could not call proc

RECOMMENDED: Click here to fix Windows errors and optimize system performance. could…

The printer requires your attention error

Download DriverFix 2. print the pages of the website using a different…